Masternode POSE_BAN Issue


I am currently running 4 Masternodes and getting close to getting a 5th… but over the last couple of weeks, I have been having issues with 3 of my Masternodes…

They have been POSE_BANNED every couple of days and I have to keep unbanning them. the weird thing is when I unban them they might be good for about 2 days then their score starts to increase and sometimes I miss it. I have checked all my settings on the node and I honestly cannot seem to figure out what is going on…

My 4th Masternode which is also got everything setup correctly is running on the same hardware etc as the others… and it does not make sense to me as to why the other 3 are getting banned…

Any assistance or guidance is greatly appreciated.

When unbanning, did you check the status on the masternode itself?
./firo-cli evoznode status

Sure have,

I check this often before unbanning them and I have not seen the status say it is banned… always say.

"state": "READY", 
"status": "Ready

But although the nodes say that the wallet says they are pose_banned…

I honestly am not sure what is going on…

Did you checked the output of ./firo-cli getinfo ? There is a chance that it is running on an outdated version of firod.

Honestly did not think of that.

I am running “version”: 141101

If this is indeed an outdated version how do I update it?

Current version is 141301. You’ll need to:

  1. Download the latest version from Release Firo v0.14.13.1 Lelantus Spark · firoorg/firo · GitHub
  2. Upgrade your firod on the masternode. Since you are going from v0.14.11.1 to v0.14.13.1, you’ll need to adjust some parts of the guide, specifically part 4.
  3. Before starting the new version of firod, you need to set it to reindex.

Ok, I have done that for all 3 servers… I assume that I only needed to type

./firod -daemon -reindex-chainstate

In the console for the servers which showed:

Firo server starting

Now I tried to do the ./firo-cli getinfo

But it is just saying:
(make sure server is running and you are connecting to the correct RPC port)

Is this normal?

I also updated the server that had not been getting banned and it seems to have updated with no problem the ./firo-cli getinfo


error code: -28
error message:
Loading block index…

Which I assume has worked without a hitch…

Just want to ensure the other 3 above with the “make sure server is running” is what is meant to occur.


For the three servers, check the logs for more info. Pay attention to any mentions of corruption or errors.

Did you confirm that the server that was not banned was running an outdated version?

Yeah, the one server that was not banned was running a slightly outdated version, and seems to be working now and so do the others except I had to run `./firod -daemon -reindex Instead of ./firod -daemon -reindex-chainstate… So far unsure how it will go at this time, Still waiting for one to finish reindexing, Ill leave these for a good 2-4 days to see what happens and will report back here with an outcome.

Thanks Anwar.

So… I have left this for a the week and the 3 have been POSE_BANNED… AGAIN!..

What else could be the issue?

On the masternode itself, check the following:
./firo-cli getinfo
./firo-cli evoznode status

Please post the full output of getinfo

Most likely you are is happening partial connection loss
read Troubleshooting masternode: PoSe score and PoSe ban

Here is the ouput of the GetInfo…

root@ubuntu-s-1vcpu-1gb-nyc1-01:~/firo-ab389d8bbe78/bin# ./firo-cli getinfo
“version”: 141301,
“protocolversion”: 90031,
“walletversion”: 130000,
“balance”: 0.00000000,
“blocks”: 836034,
“timeoffset”: -4,
“connections”: 10,
“proxy”: “”,
“difficulty”: 3134.555236943494,
“testnet”: false,
“keypoololdest”: 1664615286,
“keypoolsize”: 101,
“paytxfee”: 0.00000000,
“mininput”: 0.00001000,
“relayfee”: 0.00001000,
“errors”: “”

And the Output for the evoznode status:

root@ubuntu-s-1vcpu-1gb-nyc1-01:~/firo-ab389d8bbe78/bin# ./firo-cli evoznode status
“outpoint”: “COutPoint(0000000000000000000000000000000000000000000000000000000000000000, 4294967295)”,
“service”: “”,
“state”: “POSE_BANNED”,
“status”: “Znode was PoSe banned”

All 3 are like this… I have tried so many times to make them work as discussed above… this just keeps happening…

I have repeatedly unbanned them and am not sure what to do now i have read the Troubleshooting Guide and nothing in there seems to help…

Should I be cutting my loses? or is there a way to completely reinstall the server and keep the same master nodes connected to them?

Were the unban commands issued while the masternodes are still reindexing, or after it was confirmed to finished reindex successfully?

What are the specs of the VPS? 1 vCPU 1GB of RAM? Try 2GB of RAM with 2GB of swap enabled.

You may be correct I did unban them when I reindexed them so I have unbanned them again and will see if the issue persists again.

they are all running on

1 VCPU and 1GB RAM…

But it’s only these 3 that keep getting banned the 4th one runs the same specs and has absolutely no issues.

Ill see if I can increase the swap anyway and see how it goes ill report back soon. I am hoping it was cause they were reindexing but we shall see…

  1. Right now when they are unbanned, could you check their ./firo-cli evoznode status + getinfo?
  2. Do they have enough free space? df -h
  3. How is memory and swap looking? free -m