Design Comments on Campfire IOS app, ton of bugs and lost the wallet, can't restore wallet


Tested the IOS campfire wallet and found a few design issues and bugs, and some serious bugs.

  1. Restore wallet does not work?

Tried to restore with two different seed phrases, I just get infinite loading. Been loading for 15 minutes, nothing is happening.

  1. Typing in seed phrase, this is buggy. When you click on a word on IOS, it also add a space at the end of the word. Then you get an error:

  1. Pasting in a seed phrase does not work. You get this:

  1. When sending, if you click note, amount etc. It tries to update some values and it some weird animations that jump back and forth

  2. FaceId missing

  3. Notifications does not work / does not exist. Should get a notification when someone sends you Firo.

  4. The wording of available and full is confusing, should maybe be “total”?

  5. paste does not work for sending, it does not seem to be a text field. So I can’t select it and then click paste as you normally do on IOS.

  6. More serious bug, I created a new wallet, then I clicked back, and back again, suddenly I am back at the create seed phrase page. I click back again, the seed phrase is gone. The wallet is gone. And I get “create new wallet”. I stop the app. Start it again. The wallet I have created is gone. Try to restore the wallet that I just created, but this does not work… I sent some Firo to test, now I can’t access that Firo

This app need some work and I really don’t understand how this has not been tested properly. I try the app and it takes 5 minutes before I find a ton of bugs and loose the wallet, and I am unable to access my Firo.


How can I get access to my Firo again? I tried to type the seed phrase into electrum, but the Firo has been automatically minted so can’t access it with electrum.


Hello, this is Diego, the owner of Cypher Stack who coded up the wallet. We’re taking a look into the issues you brought up and will be releasing a new version in the next couple of days.

Rest assured that, as always, your funds are safe if you have your seed written down.

In regards to testing, we did in fact do large amounts, and have had some issues reproducing several of yours issues. We’re obviously not saying your lying, so we increased our testing capabilities and have indeed been able to reproduce a couple of the bugs. They should be fixed in our coming update.

We thank you so much for doing this testing for us, and we’re more than happy to compensate you a few Firo for the work you’ve done for us here. Think of it as a bounty for the bugs you’ve found. :wink: It won’t be too much, but we’re happy to do what we can. Shoot me a DM and we’ll get that sorted out.

Again, new update coming soon. Hopefully it’ll solve a majority of the issues.


Happy to help out, I can try to provide more details if you can’t reproduce the issues, can record my screen on IOS for example, that would probably be more helpful. Sent a DM.

Back with more feedback for the new version. Just want it to be a great app. Good news, was able to restore the wallet now, so that works.

  1. Sending

First of all these buttons are very small, it is not really that clear that one is remove, one is contact list and one is qr code. You want to send, then the next step should be 90% of the time, scan, then you also don’t need to fill out amount and note. This is included in the QR code data and not something you should type in anyway.

If you take a look at other apps, it is very simple. You click send, then you have two choices. QR code or address book. Actually you can just open camera and QR scanning when you clicks send if you ask me. And have the option to go back and fill in an address.

It is also a bug where the value in USD is not shown?

  1. Mix of Pin and FaceId,

FaceId works, that is great. But it’s a weird bug there.

Posted a video here. Both confirm with pin and face id is shown at the same time. The face id is valid and the transaction is confirmed. But the fill out pin window is still visible in the background. Should just show FaceId if that is enabled, and if that does not work on the third attempt, show pin.

Second issue, as soon as you send, let say you have 10 FIRO, if you send 2 FIRO. You stay at the send window after sending. Not an overview window. When you have sent a transaction, you are done with sending and should be redirected back to the home page. Second issue is that, as soon as you click send it says 0 FIRO available. So it kind of look like you lost all your FIRO.

I understand that is because we anonymize the FIRO, but still. Should not suddenly say you lost all your FIRO when you click send. Should show pending or in progress or something else. If someone has 1000 FIRO, send 1 FIRO, and then they get “You can now send 0 FIRO”. I am sure that would freak someone out.

  1. Share you address

This is all wrong, when you share something on Iphone it looks something like this:

You can choose, AirDrop, Messages, Email, Facebook, Your recent contacts etc.

What is this? You can not select note or amount, and it is no option to share? How am I supposed to use this? Also, make the "Tap address … " text field clickable, it’s more intuitive to click there

It should also be such that, if I can a sms, email, facebook message or something, with a payment request, it should open the campfire app when you click the link.

  1. Sending is super slow

Sending a transaction took almost 60 seconds! That is quite slow.


Also, when I want to send the full amount on the wallet. I have to type it in. I makes sense that when I click on “you can spend …”, that this amount is filled into the amount field. But nothing happens. You have to type in the full amount.

I think i broke the app, uploaded the video here:

  1. Sent all my firo to another wallet
  2. open the wallet, for some reason the sending transaction window show up. It’s 30 min since I already sent all the Firo from the wallet, so that is strange.
  3. I close the app, open it again
  4. First FaceId does not work, only pin show up
  5. Go back and open it again, this time faceId works.
  6. My wallet is empty, but it shows 5 Firo, even when I click sync
  7. Try to send, this of course fails.
  8. Try to sync again, still shows the wrong amount. All Firo has been sent to another wallet. So should say 0 Firo.
1 Like

Hello, we will go ahead and look at the other bugs you have found and they should be resolved in the next update. In the meantime it looks like maybe the app was shut down before the send was fully finished and the local database was not updated. In the mean time you can restore the wallet again. and it will show as empty like you expected. We will be sure to make that the next update will have more descriptive errors, so that users can know what to do. The next update will also make it so you don’t have to make another restored wallet to see the correct amount when an issue like the one you mentioned happens again, rather there will be an option in the settings to do a full rescan.


Thanks for the reply, yes that makes sense.

But, I am quite sure I clicked send, waited for over a minute with the app open. Watched the transactions show up in another wallet. And then navigated back to the main window.

Then, after 20-30 minutes I opened the app again, and it showed the loading transaction screen, for the transaction I had already completed.